Čo znamená koniec životnosti PHP 5.6 pre používateľov WordPress?

PHP 5.6 je najpoužívanejšie vedľajšia verzia programovacieho jazyka na webe. Jazyk PHP sa používa na 79 % webových stránok, na ktorých je známy jazyk na strane servera. PHP 5 sa používa na 58 % webu a PHP 5.6 sa používa na približne štvrtine všetkých webových stránok. Nebolo by prehnané povedať, že existujú milióny webových stránok s PHP 5.6 – a tiež milióny používajúce staršie verzie PHP.

The štatistiky pre WordPress sú v rovnakom tempe: 35 % stránok WordPress beží na PHP 5.6. Pre štyri roky starý softvér zostáva PHP 5.6 pozoruhodne úspešné. Tiež nie je podporovaný a nedostáva ani opravy chýb, ani aktualizácie zabezpečenia.

Do konca decembra 2018 nebolo PHP 5.6 aktívne podporované dva roky, počas ktorých nedostalo žiadne vydania s opravou chýb. Jeho oficiálny koniec životnosti bol dosiahnutý, keď sa rok 2018 chýli ku koncu, a odteraz už nebude aktualizovaný ani pre kritické bezpečnostné problémy.

PHP 5.6 a WordPress

WordPress odporúča poskytovateľom hostingu podpora PHP 7.3, čo je najnovšia verzia. V čase písania tohto článku budú moderné verzie WordPressu bežať na oveľa starších verziách PHP, späť na PHP 5.2.4, ale ako vývojári WordPress objasňujú, používanie staršej verzie môže vystaviť váš web bezpečnostným chybám.

Keď bude verzia WordPress 5.1 vydaná neskôr v tomto roku, PHP 5.6 bude stať sa minimálnou podporovanou verzioua stránky používajúce staršie verzie môžu začať mať problémy s kompatibilitou. Existujú predbežné plány, aby sa PHP 7 stala minimálnou podporovanou verziou už koncom roka 2019, ale vzhľadom na obrovskú základňu inštalácie pre WordPress na PHP 5.6 je neisté, že sa tak skutočne stane.

Čítať:  Ako pridať voľné pracovné miesta vo WordPress pomocou WP Job Openings

Vaša stránka bude naďalej fungovať. Hoci PHP 5.6 už nie je podporované, stránky WordPress, ktoré ho používajú, budú fungovať aj v dohľadnej budúcnosti. Vývojári WordPress uprednostňujú vlastníkov stránok, aby používali aktuálne verzie, ale zaisťujú, že WordPress je kompatibilný so staršími verziami. Nie je však zaručené, že WordPress zostane navždy kompatibilný so staršími verziami alebo že vývojári budú naďalej podporovať staré verzie tak dlho, ako majú.

Používanie starších verzií predstavuje bezpečnostné riziko. Ak sa v PHP 5.6 objaví kritická zraniteľnosť, nebude opravená. Nie je možné povedať, aké veľké riziko to predstavuje, pretože nikto nevie, či v PHP 5.6 existujú nejaké kritické bezpečnostné chyby. Za posledných pár rokov bolo v PHP 5.6 objavených a opravených množstvo zraniteľností týkajúcich sa odmietnutia služby, ale len málo kritických zraniteľností so vzdialeným spustením kódu alebo eskaláciou privilégií. Po štyroch rokoch nie je riziko odhalenia zraniteľností vysoké, no nie je ani nulové.

Nové stránky WordPress by mali používať podporované verzie PHP. Neexistuje žiadny dobrý dôvod na spustenie novej stránky WordPress na nepodporovanej verzii PHP. Poskytovatelia hostingu, ktorí používajú zastarané verzie pre nové stránky, sú nedbalí a vedome vystavujú svojich klientov riziku. Zodpovední poskytovatelia hostingu pravidelne inovujú PHP na svojich hostingových platformách. Hostinger ponúka najnovšiu podporovanú verziu pre nové hostingové účty WordPress, aj keď naďalej podporujeme staršie verzie pre klientov, ktorí ich potrebujú.

Čítať:  6 najlepších novoročných predsavzatí pre vašu firmu

Stručne povedané, aj keď nie je potrebné panikáriť, klienti hosťovania so stránkami založenými na PHP 5.6 by mali zvážiť aktualizáciu na novšiu verziu, pretože pri používaní starších verzií PHP existuje nezanedbateľné bezpečnostné riziko.

Nové Publikácie:

ODPORÚČANIE